记一次被迫升级
玩物志•
前几天下午(2022年10月16日)我打开了博客,页面中出现的并不是博客的首页,是一行报错信息(\Widgt\Archive)。
当时没有在意,以为是服务器资源占用过高数据库崩溃了,重启一下服务器就可以解决。登录宝塔面板查看了运行信息,资源并没有占用过高,我就直接进行了服务器重启。
服务器重启后博客依然无法访问,仍会显示(\Widgt\Archive)访问博客后台是可以的,但进行登录就会出现500的错误代码。
无奈之下只能求助大佬来帮忙解决问题,大佬首先是让我开启debug看一下详细的报错信息,看看是不是因为那个插件或者主题的问题。
typecho 开启 debug
首先我们找到 typecho 根目录 config.inc.php 文件 然后在里面加上开启调试代码即可
typecho开启debug模式
define('__TYPECHO_DEBUG__', true);`开启debug后显示是由于程序的var文件夹的某个文件出现了问题才导致的(\Widgt\Archive)错误。
我的能力有限无法解决,无奈之下把typecho进行了升级从1.1正式版升级到了1.2。升级后问题得到了解决,可1.1的部分插件与1.2不兼容,最主要的AutoBackup(备份插件)以及Comment2Mail(邮件提醒插件)的旧版本都不适用于1.2版本,又把插件进行了升级。
不想更新的原因一个是因为程序的变化不大,感觉没有必要更新。还有就是主题可能会不支持1.2和旧的插件,主要还是自己懒... ...
将程序以及插件更新后发现还少了一样,当然是更新文章和主题了,哈哈。
于是主题进行了一下修改:
1:主题更新了版本号;
2:主题适配了Links(友情链接插件)以前只能在独立页面中通过写代码的传统方式添加链接;
3:主题添加了一个1-6级标题的样式;
4:主题更新了一个新的引用样式;
5:主题增加了张洪大佬的Heo表情;
ps:这就是新的引用样式
后记:
这就是要更新的文章和新的标题样式~

